Geutebruck G-Cam and G-Code HTML Injection and Multiple OS Command Injection Vulnerabilities

Geutebruck G-Cam and G-Code are prone to an HTML-injection vulnerability and multiple OS command-injection vulnerabilities.

Successful exploits will allow attacker-supplied HTML and script code to run in the context of the affected browser, potentially allowing the attacker to steal cookie-based authentication credentials or to control how the site is rendered to the user and inject and execute arbitrary commands. Other attacks are also possible.

The following products of Geutebruck are affected:

G-Code EEC-2xxx version 1.12.0.25 and prior
G-Cam EBC-21xx version 1.12.0.25 and prior
G-Cam EFD-22xx version 1.12.0.25 and prior
G-Cam ETHC-22xx version 1.12.0.25 and prior
G-Cam EWPC-22xx version 1.12.0.25 and prior


 

Privacy Statement
Copyright 2010, SecurityFocus