GNU CFEngine AuthenticationDialogue Remote Heap Based Buffer Overrun Vulnerability

Solution:
Gentoo has released an advisory to provide updates. Updates may be applied with the following commands:
emerge sync
emerge -pv ">=net-misc/cfengine-2.1.8"
emerge ">=net-misc/cfengine-2.1.8"

The vendor has released an update to address this issue:


GNU Cfengine 2.0 .0

GNU Cfengine 2.0 .8

GNU Cfengine 2.0 .8p1

GNU Cfengine 2.0.1

GNU Cfengine 2.0.2

GNU Cfengine 2.0.3

GNU Cfengine 2.0.4

GNU Cfengine 2.0.5

GNU Cfengine 2.0.5 b1

GNU Cfengine 2.0.5 pre2

GNU Cfengine 2.0.5 pre

GNU Cfengine 2.0.6

GNU Cfengine 2.0.7

GNU Cfengine 2.0.7 p1

GNU Cfengine 2.0.7 p3

GNU Cfengine 2.0.7 p2

GNU Cfengine 2.1 .0a8

GNU Cfengine 2.1 .0a9

GNU Cfengine 2.1 .0a6

GNU Cfengine 2.1.7 p1


 

Privacy Statement
Copyright 2010, SecurityFocus