libpng CVE-2017-12652 Security Bypass Vulnerability

Bugtraq ID: 109269
Class: Input Validation Error
CVE: CVE-2017-12652
Remote: Yes
Local: No
Published: Jul 10 2019 12:00AM
Updated: Jul 10 2019 12:00AM
Credit: The vendor reported this issue.
Vulnerable: libpng libpng 1.6.27
libpng libpng 1.6.20
libpng libpng 1.6.19
libpng libpng 1.6.16
libpng libpng 1.6.15
libpng libpng 1.5.26
libpng libpng 1.5.25
libpng libpng 1.5.24
libpng libpng 1.5.21
libpng libpng 1.5.5
libpng libpng 1.5.4
libpng libpng 1.4.19
libpng libpng 1.4.18
libpng libpng 1.4.17
libpng libpng 1.4.10
libpng libpng 1.4.9
libpng libpng 1.4.8
libpng libpng 1.4.2
libpng libpng 1.4.1
libpng libpng 1.4
libpng libpng 1.2.56
libpng libpng 1.2.55
libpng libpng 1.2.54
libpng libpng 1.2.43
libpng libpng 1.2.42
libpng libpng 1.2.40
libpng libpng 1.2.29
libpng libpng 1.2.25
libpng libpng 1.2.23
libpng libpng 1.2.22
libpng libpng 1.2.21
libpng libpng 1.2.20
libpng libpng 1.2.19
libpng libpng 1.2.18
libpng libpng 1.2.16
libpng libpng 1.0.44
libpng libpng 1.0.43
libpng libpng 1.0.42
libpng libpng 1.0.41
libpng libpng 1.0.40
libpng libpng 1.0.35
libpng libpng 1.0.33
libpng libpng 1.0.32
libpng libpng 1.0.15
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
libpng libpng 1.0.14
+ Redhat Linux 7.3 i386
+ Redhat Linux 7.2 ia64
+ Redhat Linux 7.2 i386
+ Redhat Linux 7.1 i386
+ Redhat Linux 7.0 i386
+ Redhat Linux 6.2 i386
libpng libpng 1.0.13
libpng libpng 1.0.12
- Caldera OpenLinux Server 3.1.1
- Caldera OpenLinux Server 3.1
- Caldera OpenLinux Workstation 3.1.1
- Caldera OpenLinux Workstation 3.1
+ Debian Linux 3.0
+ Mandriva Linux Mandrake 8.1 ia64
+ Mandriva Linux Mandrake 8.1
+ SuSE Linux 8.0
+ SuSE Linux 7.3 sparc
+ SuSE Linux 7.3 ppc
+ SuSE Linux 7.3
libpng libpng 1.0.11
libpng libpng 1.0.10
+ SuSE Linux 7.2
libpng libpng 1.0
+ SuSE Linux 7.0 sparc
+ SuSE Linux 7.0 ppc
+ SuSE Linux 7.0 alpha
+ SuSE Linux 7.0
libpng libpng 1.6.3
libpng libpng 1.6.2
libpng libpng 1.6.11
libpng libpng 1.6.10
libpng libpng 1.6.1
libpng libpng 1.6.0
libpng libpng 1.5.9
libpng libpng 1.5.8
libpng libpng 1.5.7
libpng libpng 1.5.6
libpng libpng 1.5.2
libpng libpng 1.5.13
libpng libpng 1.5.12
libpng libpng 1.5.11
libpng libpng 1.5.10
libpng libpng 1.5
libpng libpng 1.4.7
libpng libpng 1.4.6
libpng libpng 1.4.5
libpng libpng 1.4.4
libpng libpng 1.4.11
libpng libpng 1.4
libpng libpng 1.2.6
libpng libpng 1.2.41
libpng libpng 1.2.4
libpng libpng 1.2.3
libpng libpng 1.2.28
libpng libpng 1.0.39
libpng libpng 1.0.38
libpng libpng 1.0.37
libpng libpng 1.0.34
libpng libpng 1.0.29
libpng libpng 1.0.1
libpng libpng 1.0
Not Vulnerable: libpng libpng 1.6.32


 

Privacy Statement
Copyright 2010, SecurityFocus