PEiD Malformed PE File Remote Buffer Overflow Vulnerability

A remote buffer-overflow vulnerability affects PEiD because the application fails to properly validate the length of user-supplied strings before copying them into static process buffers.

An attacker who entices an unsuspecting user to load a maliciously crafted Portable Executable (PE) file with the affected utility may exploit this issue.

The attacker may exploit this issue to execute arbitrary code with the privileges of the user that activated the vulnerable application. This may facilitate unauthorized access or privilege escalation.


 

Privacy Statement
Copyright 2010, SecurityFocus