PHPWebSite Image File Processing Remote Arbitrary PHP File Upload Vulnerability

phpWebSite is reported prone to a remote arbitrary PHP file upload vulnerability. The issue presents itself due to a lack of sanitization performed on image files that are uploaded when submitting an announcement.

A remote attacker may exploit this condition to execute arbitrary PHP code in the context of the hosting web server process.

This vulnerability is reported to affect phpWebSite versions up to an including version 0.10.0.


 

Privacy Statement
Copyright 2010, SecurityFocus