Just William's Amazon Webstore Closeup.PHP Image Parameter Cross-Site Scripting Vulnerability

Amazon Webstore is prone to a cross-site scripting vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

This issue reportedly affects Amazon Webstore version 04050100; other versions may also be vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus