PostgreSQL TSearch2 Design Error Vulnerability

The PostgreSQL 'contrib/tsearch2' module is prone to a security vulnerability. The issue occurs because the module doesn't correctly declare several functions.

Although unconfirmed, presumably this issue allows a remote user who can write SQL queries to the affected database to call these functions, which shouldn't be accessible directly from SQL commands.

This vulnerability affects PostgreSQL 7.4 and later.


 

Privacy Statement
Copyright 2010, SecurityFocus