Multiple Vendor libncurses Terminfo Buffer Overflow Vulnerability

Bugtraq ID: 2116
Class: Boundary Condition Error
CVE:
Remote: No
Local: Yes
Published: Oct 09 2000 12:00AM
Updated: Oct 09 2000 12:00AM
Credit: First posted to Bugtraq by Jouko Pynnönen <jouko@solutions.fi> on Oct 9, 2000.
Vulnerable: Turbolinux Turbolinux 6.0.5
SuSE Linux 7.0
SuSE Linux 6.3
SuSE Linux 6.2
Redhat Linux 7.2 i386
Redhat Linux 7.1 i386
Redhat Linux 7.1 alpha
Redhat Linux 7.0 i386
Redhat Linux 7.0 alpha
Redhat Linux 6.1 sparc
Redhat Linux 6.1 i386
Redhat Linux 6.1 alpha
HP Secure OS software for Linux 1.0
FreeBSD FreeBSD 5.0
FreeBSD FreeBSD 4.1.1
FreeBSD FreeBSD 4.1
FreeBSD FreeBSD 4.0
FreeBSD FreeBSD 3.5.1
FreeBSD FreeBSD 3.5
FreeBSD FreeBSD 3.4
FreeBSD FreeBSD 3.3
FreeBSD FreeBSD 3.2
FreeBSD FreeBSD 3.1
Debian Linux 2.2 sparc
Debian Linux 2.2 powerpc
Debian Linux 2.2 IA-32
Debian Linux 2.2 arm
Debian Linux 2.2 alpha
Debian Linux 2.2 68k
Not Vulnerable:


 

Privacy Statement
Copyright 2010, SecurityFocus