WikiReader URL Field Local Buffer Overflow Vulnerability

WikiReader is prone to a local buffer-overflow vulnerability because it fails to adequately bounds-check user-supplied input data to an insufficiently sized buffer.

An attacker can exploit this issue to execute arbitrary code within the context of the affected application; failed exploit attempts will result in a denial-of-service condition.

This issue affects version 1.12; other versions may also be vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus