GeoIP 'GeoIPUpdate.c' Directory Traversal Vulnerability

The 'geoip' application is prone to a directory-traversal vulnerability because it fails to properly sanitize user-supplied input.

An attacker can exploit this vulnerability to retrieve arbitrary files from the vulnerable system in the context of the affected application. Information obtained may aid in further attacks.

This issue affects versions prior to 1.4.0.

NOTE (May 20, 2011): Reports indicate that paths containing backslash ('\') or colon (':') characters on Windows platforms are not properly handled in the fix for this issue.


 

Privacy Statement
Copyright 2010, SecurityFocus