OpenOffice StarCalc Parser Unspecified Buffer Overflow Vulnerability

Bugtraq ID: 23067
Class: Boundary Condition Error
CVE: CVE-2007-0238
Remote: Yes
Local: No
Published: Dec 15 2006 12:00AM
Updated: Nov 15 2007 12:39AM
Credit: Next Generation Security is credited with the discovery of this vulnerability.
Vulnerable: Ubuntu Ubuntu Linux 5.10 powerpc
Ubuntu Ubuntu Linux 5.10 i386
Ubuntu Ubuntu Linux 5.10 amd64
Ubuntu Ubuntu Linux 6.10 powerpc
Ubuntu Ubuntu Linux 6.10 i386
Ubuntu Ubuntu Linux 6.10 amd64
Ubuntu Ubuntu Linux 6.06 LTS powerpc
Ubuntu Ubuntu Linux 6.06 LTS i386
Ubuntu Ubuntu Linux 6.06 LTS amd64
SuSE SUSE Linux Enterprise SDK 10
SuSE SUSE Linux Enterprise Desktop 10
Sun StarSuite 8
Sun StarSuite 7
Sun StarSuite 6
Sun StarOffice 7.0
Sun StarOffice 8.0
Sun StarOffice 6.0
SGI ProPack 3.0 SP6
S.u.S.E. openSUSE 10.2
S.u.S.E. Novell Linux Desktop 9
S.u.S.E. Linux Desktop 1.0
S.u.S.E. Linux 9.3 x86
S.u.S.E. Linux 10.1 x86-64
S.u.S.E. Linux 10.1 x86
S.u.S.E. Linux 10.1 ppc
S.u.S.E. Linux 10.0 x86
rPath rPath Linux 1
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux Optional Productivity Application 5 server
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Desktop 4.0
RedHat Desktop 3.0
Red Hat Enterprise Linux Desktop 5 client
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
OpenOffice OpenOffice 2.0.4
OpenOffice OpenOffice 2.0.3 -1
OpenOffice OpenOffice 2.0.3
OpenOffice OpenOffice 2.0.2
OpenOffice OpenOffice 2.0.1
OpenOffice OpenOffice 2.0 Beta
OpenOffice OpenOffice 1.9.125
OpenOffice OpenOffice 1.9.79
OpenOffice OpenOffice 1.9.29
OpenOffice OpenOffice 1.1.52
OpenOffice OpenOffice 1.1.51
OpenOffice OpenOffice 1.1.5
OpenOffice OpenOffice 1.1.4
+ Gentoo Linux
OpenOffice OpenOffice 1.1.3 -9sarge3
+ Gentoo Linux
+ Red Hat Fedora Core3
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64
OpenOffice OpenOffice 1.1.3
+ Gentoo Linux
+ Red Hat Fedora Core3
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64
OpenOffice OpenOffice 1.1.2
OpenOffice OpenOffice 1.1.1
OpenOffice OpenOffice 1.1 .0
OpenOffice OpenOffice 1.0.3
OpenOffice OpenOffice 1.0.2
OpenOffice OpenOffice 1.0.1
OpenOffice OpenOffice 2.1
Mandriva Linux Mandrake 2007.0 x86_64
Mandriva Linux Mandrake 2007.0
MandrakeSoft Corporate Server 3.0 x86_64
MandrakeSoft Corporate Server 3.0
libwpd libwpd library 0.8.4
Gentoo app-office/openoffice-bin 2.1
Gentoo app-office/openoffice 2.0.3
Foresight Linux Foresight Linux 1.1
Debian Linux 3.1 sparc
Debian Linux 3.1 s/390
Debian Linux 3.1 ppc
Debian Linux 3.1 mipsel
Debian Linux 3.1 mips
Debian Linux 3.1 m68k
Debian Linux 3.1 ia-64
Debian Linux 3.1 ia-32
Debian Linux 3.1 hppa
Debian Linux 3.1 arm
Debian Linux 3.1 amd64
Debian Linux 3.1 alpha
Debian Linux 3.1
Debian Linux 4.0 sparc
Debian Linux 4.0 s/390
Debian Linux 4.0 powerpc
Debian Linux 4.0 mipsel
Debian Linux 4.0 mips
Debian Linux 4.0 m68k
Debian Linux 4.0 ia-64
Debian Linux 4.0 ia-32
Debian Linux 4.0 hppa
Debian Linux 4.0 arm
Debian Linux 4.0 amd64
Debian Linux 4.0 alpha
Debian Linux 4.0
Avaya Interactive Response 2.0
Not Vulnerable: OpenOffice OpenOffice 2.2
Gentoo app-office/openoffice-bin 2.2
Gentoo app-office/openoffice 2.1.0-r1


 

Privacy Statement
Copyright 2010, SecurityFocus