PHP Memory Manager Sign Comparison Multiple Buffer Overflow Vulnerabilities

Bugtraq ID: 23238
Class: Boundary Condition Error
CVE:
Remote: Yes
Local: Yes
Published: Mar 31 2007 12:00AM
Updated: Apr 02 2007 08:32PM
Credit: Stefan Esser is credited with the discovery of these vulnerabilities.
Vulnerable: PHP PHP 5.2
+ Debian Linux 4.0 sparc
+ Debian Linux 4.0 s/390
+ Debian Linux 4.0 powerpc
+ Debian Linux 4.0 mipsel
+ Debian Linux 4.0 mips
+ Debian Linux 4.0 m68k
+ Debian Linux 4.0 ia-64
+ Debian Linux 4.0 ia-32
+ Debian Linux 4.0 hppa
+ Debian Linux 4.0 arm
+ Debian Linux 4.0 amd64
+ Debian Linux 4.0 alpha
+ Debian Linux 4.0
Not Vulnerable: PHP PHP 5.2.1
+ Ubuntu Ubuntu Linux 7.04 sparc
+ Ubuntu Ubuntu Linux 7.04 powerpc
+ Ubuntu Ubuntu Linux 7.04 i386
+ Ubuntu Ubuntu Linux 7.04 amd64


 

Privacy Statement
Copyright 2010, SecurityFocus