MySQL Rename Table Function Access Validation Vulnerability

MySQL is prone to an access-validation vulnerability because it fails to perform adequate access control.

Attackers can exploit this issue to rename arbitrary tables. This could result in denial-of-service conditions and may aid in other attacks.

Versions prior to MySQL 4.1.23, 5.0.42, and 5.1.18 are vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus