Autonomy KeyView Module Multiple Buffer Overflow Vulnerabilities

Autonomy KeyView module is prone to multiple stack- and heap-based buffer-overflow vulnerabilities because it fails to perform adequate boundary checks on user-supplied data before copying it to insufficiently sized buffers.

Exploiting these issues will allow an attacker to corrupt memory and to cause denial-of-service conditions or potentially to execute arbitrary code in the context of the application using the module.

Multiple products using the KeyView module are affected.


 

Privacy Statement
Copyright 2010, SecurityFocus