Drupal Multiple Cross Site Scripting and Request Forgery Vulnerabilities

The applications are prone to multiple cross-site scripting vulnerabilities because the software fails to sufficiently sanitize user-supplied input. The Internationalization module is also prone to cross-site request forgery attacks while performing node translations.

An attacker may leverage the cross-site scripting issue to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may allow the attacker to steal cookie-based authentication credentials and to launch other attacks. The attacker can exploit the cross-site request-forgery issue by tricking a victim into following a specially crafted HTTP request designed to perform some action on the attacker's behalf using a victim's currently active session.

The following versions are affected:

Internationalization (i18n) for Drupal 5.x before Internationalization 5.x-2.3 and 5.x-1.1
Internationalization (i18n) for Drupal 6.x before Internationalization 6.x-1.0-beta1
Localizer for Drupal 5.x before Localizer 5.x-3.4, 5.x-2.1 and 5.x-1.11


 

Privacy Statement
Copyright 2010, SecurityFocus