ALFTP FTP Client 'LIST' Command Directory Traversal Vulnerability

ALFTP is prone to a directory-traversal vulnerability because the application fails to sufficiently sanitize user-supplied input. This issue occurs in the FTP client.

Exploiting this issue will allow an attacker to write arbitrary files to locations outside of the application's current directory. This could help the attacker launch further attacks.

ALFTP 4.1 beta 2 (English) and 5.0 (Korean) are vulnerable; other versions may also be affected.


 

Privacy Statement
Copyright 2010, SecurityFocus