OpenTTD Multiple Buffer Overflow Vulnerabilities

OpenTTD is prone to multiple buffer-overflow vulnerabilities because it fails to adequately bounds-check user-supplied input before copying it to insufficiently sized buffers.

Successfully exploiting these issues may allow an attacker to execute arbitrary code with the privileges of the user running the affected application. Failed exploit attempts will likely crash the application.

These issues affect versions prior to OpenTTD 0.6.2.


 

Privacy Statement
Copyright 2010, SecurityFocus