WebGUI Security Bypass and Multiple Cross Site Scripting Vulnerabilities

WebGUI is prone to a security-bypass vulnerability and multiple cross-site scripting vulnerabilities because it fails to properly validate user credentials and sanitize user-supplied input.

An attacker may leverage the cross-site scripting issues to execute arbitrary script code in the browser of an unsuspecting user in the context of the affected site. This may let the attacker steal cookie-based authentication credentials and launch other attacks.

The attacker may leverage the security-bypass issue to reset an arbitrary user's password and gain access to the user's account.

WebGUI 7.5.25 is vulnerable; other versions may also be affected.


 

Privacy Statement
Copyright 2010, SecurityFocus