MODx CMS Cross Site Scripting and Remote File Include Vulnerabilities

MODx CMS is prone to a cross-site scripting vulnerability and a remote file-include vulnerability because it fails to sufficiently sanitize user-supplied data.

An attacker can exploit these issues to execute malicious PHP code in the context of the webserver process. This may allow the attacker to compromise the application and the underlying system. Attackers may also execute script code in an unsuspecting user's browser or steal cookie-based authentication credentials; other attacks are also possible.

These issues affect MODx CMS 0.9.6.2; other versions may also be vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus