Apple Mac OS X Xterm Local Privilege Escalation Vulnerability

Apple Mac OS X is prone to a local privilege-escalation vulnerability that affects XTerm when run in conjunction with Luit.

Local attackers may exploit this issue to gain elevated privileges; other attacks may also be possible.

This issue affects Mac OS X 10.4.11 and 10.5.6. Other distributions that include XTerm and Luit may also be vulnerable, but this has not been confirmed.

NOTE: This issue was previously covered in BID 33759 (Apple Mac OS X 2009-001 Multiple Security Vulnerabilities), but has been assigned its own record to better document it.


 

Privacy Statement
Copyright 2010, SecurityFocus