Apple Mac OS X SMB Component Unspecified Buffer Overflow Vulnerability

Apple Mac OS X is prone to a buffer-overflow vulnerability that occurs in the SMB component.

An attacker can exploit this issue to execute arbitrary code with SYSTEM-level privileges. Successful exploits will facilitate in the complete compromise of affected computers. Failed exploit attempts will result in a denial-of-service condition.

NOTE: This issue was previously covered in BID 33759 (Apple Mac OS X 2009-001 Multiple Security Vulnerabilities), but has been assigned its own record to better document it.

OS X 10.5.6 and OS X Server 10.5.6 are vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus