IBM AIX 'pppdial' Local Buffer Overflow Vulnerability

The IBM AIX 'pppdial' program is prone to a buffer-overflow vulnerability because it fails to perform adequate boundary checks on user-supplied data.

A local attacker can exploit this issue to execute arbitrary code as the affected process, possibly resulting in elevated privileges. Failed exploit attempts will likely cause denial-of-service conditions.

This issue affects AIX 5.3 and 6.1.


 

Privacy Statement
Copyright 2010, SecurityFocus