Moodle TeX Filter Remote File Disclosure Vulnerability

Moodle is prone to a remote file-disclosure vulnerability because it fails to properly sanitize user-supplied input.

An attacker can exploit this vulnerability to view local files in the context of the webserver process. This may aid in further attacks.

Versions prior to the following are vulnerable:

Moodle 1.6.9+
Moodle 1.7.7+
Moodle 1.8.9
Moodle 1.9.5


 

Privacy Statement
Copyright 2010, SecurityFocus