MapServer Multiple Security Vulnerabilities

Solution:
The vendor has released updates to address these issues. Please see the references for more information.

UPDATE (June 22, 2009): Fixes for the buffer-overflow vulnerable tracked by CVE-2009-0840 are incomplete; MapServer 4.10.4 and 5.2.2 may still be vulnerable to this issue.


Debian Linux 4.0 arm

Debian Linux 5.0 ia-64

Debian Linux 4.0 powerpc

Debian Linux 4.0 m68k

Debian Linux 5.0 alpha

Debian Linux 5.0 ia-32

Debian Linux 5.0 s/390

Debian Linux 5.0 mipsel

Debian Linux 4.0 amd64

Debian Linux 4.0 ia-32

Debian Linux 5.0 hppa

Debian Linux 4.0 hppa

Debian Linux 4.0 sparc

Debian Linux 4.0 s/390

Debian Linux 5.0 m68k

Debian Linux 5.0 arm

Debian Linux 4.0 armel

Debian Linux 4.0 alpha

Debian Linux 5.0 armel

Debian Linux 5.0

Debian Linux 4.0

Debian Linux 5.0 amd64

Debian Linux 4.0 mipsel

Debian Linux 5.0 mips

Debian Linux 5.0 powerpc

Debian Linux 4.0 ia-64

Debian Linux 4.0 mips

Debian Linux 5.0 sparc

Regents of the University of Minnesota MapServer 4.10.3

Regents of the University of Minnesota MapServer 5.2.1


 

Privacy Statement
Copyright 2010, SecurityFocus