Adobe Reader and Acrobat 9.1.1 and Prior Multiple Remote Vulnerabilities

Adobe Reader and Acrobat are prone to multiple remote vulnerabilities.

An attacker can exploit these issues by tricking a victim into opening a malicious file to execute arbitrary code and to cause denial-of-service conditions.

The following individual records have been created to better document some of these issues:

35298 Adobe Reader and Acrobat JBIG2 Filter Unspecified Memory Corruption Vulnerability
35295 Adobe Reader and Acrobat Multiple Unspecified Remote Heap Buffer Overflow Vulnerabilities
35294 Adobe Reader and Acrobat 9.1.1 and Prior Integer Overflow Vulnerability
35296 Adobe Reader and Acrobat 9.1.1 and Prior Unspecified Memory Corruption Vulnerability
35289 Adobe Reader and Acrobat Unspecified Memory Corruption Vulnerability
35293 Adobe Reader and Acrobat JBIG 'Halftone Region' Remote Heap Buffer Overflow Vulnerability
35291 Adobe Reader and Acrobat JBIG Halftone Region Grid Area Remote Heap Buffer Overflow Vulnerability
35282 Adobe Reader and Acrobat U3D Model Remote Stack Buffer Overflow Vulnerability
35299 Adobe Reader and Acrobat JBIG 'Pattern Dictionary' Remote Heap Buffer Overflow Vulnerability
35300 Adobe Reader & Acrobat JBIG Pattern Dictionary Allocation Remote Heap Buffer Overflow Vulnerability
35301 Adobe Reader and Acrobat JBIG 'Halftone Region' Remote Heap Buffer Overflow Vulnerability
35302 Adobe Reader and Acrobat Huffman-encoded JBIG2 Text Heap Overflow Vulnerability
35303 Adobe Reader and Acrobat JBIG Segments 'Text Region' Memory Corruption Vulnerability

The vendor reports other unspecified security issues have also been addressed. Information regarding these issues is currently not available. We will update this BID as more information emerges.


 

Privacy Statement
Copyright 2010, SecurityFocus