RETIRED: Apple iPhone and iPod touch Prior to Version 3.0 Multiple Vulnerabilities

Apple iPhone and iPod touch are prone to multiple vulnerabilities.

Successfully exploiting these issues may allow attackers to bypass security restrictions, obtain sensitive information, or cause denial-of-service conditions.

These issues affect the following:

iPhone OS 1.0 through 2.2.1
iPhone OS for iPod touch 1.1 through 2.2.1

This BID is being retired. The following individual records have been created to better document these issues:

35433 Apple iPhone and iPod touch MPEG-4 Video Codec Denial of Service Vulnerability
35434 Apple iPhone and iPod touch Mail Client Information Disclosure Weakness
35436 Apple iPhone and iPod touch Configuration Profile Handling Information Disclosure Vulnerability
35425 Apple iPhone Call Approval Dialog Security Bypass Vulnerability
35445 Apple iPhone and iPod touch ICMP Echo Request Remote Denial of Service Vulnerability
35446 Apple iPhone and iPod touch HTMLSelectElement Denial of Service Vulnerability
35447 Apple iPhone and iPod touch Untrusted Certificate Exception Information Disclosure Vulnerability
35448 Apple iPhone and iPod touch Safari Search History Information Disclosure Vulnerability


 

Privacy Statement
Copyright 2010, SecurityFocus