GNOME libgtop_daemon Remote Buffer Overflow Vulnerability

The GNOME libgtop_daemon is used to monitor processes running on a remote system.

Under some conditions, when a remote connection fails, user supplied input is used as within a log message. As part of this operation, the input is copied from a buffer in an unsafe manner. This will overwrite part of the stack, possibly leading to remote code execution as the libgtop_daemon user.

Older versions of libgtop_daemon may share this vulnerability.


 

Privacy Statement
Copyright 2010, SecurityFocus