Apple iPhone and iPod Touch MP3 and AAC File Heap Buffer Overflow Vulnerability

Bugtraq ID: 36338
Class: Boundary Condition Error
CVE: CVE-2009-2206
Remote: Yes
Local: Yes
Published: Sep 09 2009 12:00AM
Updated: Sep 14 2009 08:31PM
Credit: Tobias Klein of trapkit.de
Vulnerable: Apple iPod Touch 2.2.1
Apple iPod Touch 2.0.2
Apple iPod Touch 2.0.1
Apple iPod Touch 1.1.4
Apple iPod Touch 1.1.3
Apple iPod Touch 1.1.2
Apple iPod Touch 1.1.1
Apple iPod Touch 3.0
Apple iPod Touch 2.2
Apple iPod Touch 2.1
Apple iPod Touch 2.0
Apple iPod Touch 1.1
Apple iPod Touch 0
Apple iPhone 3.0.1
Apple iPhone 2.2.1
Apple iPhone 2.0.2
Apple iPhone 2.0.1
Apple iPhone 1.1.4
Apple iPhone 1.1.3
Apple iPhone 1.1.2
Apple iPhone 1.1.1
Apple iPhone 1.0.2
Apple iPhone 1.0.1
Apple iPhone 3.0
Apple iPhone 2.2
Apple iPhone 2.1
Apple iPhone 2.0
Apple iPhone 1.1
Apple iPhone 1
Apple iPhone 0
Not Vulnerable: Apple iPod Touch 3.1.1
Apple iPhone 3.1


 

Privacy Statement
Copyright 2010, SecurityFocus