nginx HTTP Request Remote Buffer Overflow Vulnerability

Bugtraq ID: 36384
Class: Boundary Condition Error
CVE: CVE-2009-2629
Remote: Yes
Local: No
Published: Sep 14 2009 12:00AM
Updated: May 07 2015 05:02PM
Credit: Chris Ries
Vulnerable: Igor Sysoev nginx 0.8.14
Igor Sysoev nginx 0.7.61
Igor Sysoev nginx 0.6.38
Igor Sysoev nginx 0.5.37
Igor Sysoev nginx 0
Gentoo Linux
Debian Linux 5.0 sparc
Debian Linux 5.0 s/390
Debian Linux 5.0 powerpc
Debian Linux 5.0 mipsel
Debian Linux 5.0 mips
Debian Linux 5.0 m68k
Debian Linux 5.0 ia-64
Debian Linux 5.0 ia-32
Debian Linux 5.0 hppa
Debian Linux 5.0 armel
Debian Linux 5.0 arm
Debian Linux 5.0 amd64
Debian Linux 5.0 alpha
Debian Linux 5.0
Debian Linux 4.0 sparc
Debian Linux 4.0 s/390
Debian Linux 4.0 powerpc
Debian Linux 4.0 mipsel
Debian Linux 4.0 mips
Debian Linux 4.0 m68k
Debian Linux 4.0 ia-64
Debian Linux 4.0 ia-32
Debian Linux 4.0 hppa
Debian Linux 4.0 armel
Not Vulnerable: Igor Sysoev nginx 0.8.15
Igor Sysoev nginx 0.7.62
Igor Sysoev nginx 0.6.39
Igor Sysoev nginx 0.5.38


 

Privacy Statement
Copyright 2010, SecurityFocus