Photobox Uploader ActiveX Control URL Parsing Stack Buffer Overflow Vulnerability

Photobox Uploader is prone to a stack-based buffer-overflow vulnerability because the application fails to perform adequate boundary checks on user-supplied data.

Successful exploits allow remote attackers to execute arbitrary code in the context of the application using the ActiveX control (typically Internet Explorer). Failed exploit attempts will likely result in denial-of-service conditions.

Photobox Uploader 2.2.0.6 is vulnerable; other products or versions may also be affected.


 

Privacy Statement
Copyright 2010, SecurityFocus