PostgreSQL JOIN Hashtable Size Integer Overflow Denial Of Service Vulnerability

Bugtraq ID: 38619
Class: Boundary Condition Error
CVE: CVE-2010-0733
Remote: Yes
Local: No
Published: Oct 28 2009 12:00AM
Updated: Oct 25 2011 07:22PM
Credit: Bernt Marius Johnsen
Vulnerable: SuSE SUSE Linux Enterprise 11
SuSE SUSE Linux Enterprise 10 SP3
S.u.S.E. openSUSE 11.2
S.u.S.E. openSUSE 11.1
S.u.S.E. openSUSE 11.0
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Enterprise Linux Desktop Workstation 5 client
RedHat Enterprise Linux Desktop version 4
RedHat Desktop 3.0
Red Hat Enterprise Linux Desktop 5 client
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Red Hat Enterprise Linux 5 Server
PostgreSQL PostgreSQL 8.4.1
PostgreSQL PostgreSQL 8.3.9
PostgreSQL PostgreSQL 8.3.8
PostgreSQL PostgreSQL 8.3.6
PostgreSQL PostgreSQL 8.2.15
PostgreSQL PostgreSQL 8.2.14
PostgreSQL PostgreSQL 8.2.6
PostgreSQL PostgreSQL 8.2.4
PostgreSQL PostgreSQL 8.2.3
PostgreSQL PostgreSQL 8.2.2
PostgreSQL PostgreSQL 8.2
PostgreSQL PostgreSQL 8.1.19
PostgreSQL PostgreSQL 8.1.18
PostgreSQL PostgreSQL 8.1.11
PostgreSQL PostgreSQL 8.1.9
PostgreSQL PostgreSQL 8.1.8
PostgreSQL PostgreSQL 8.1.5
PostgreSQL PostgreSQL 8.1.4
PostgreSQL PostgreSQL 8.1.3
PostgreSQL PostgreSQL 8.1.1
PostgreSQL PostgreSQL 8.0.317
PostgreSQL PostgreSQL 8.0.23
PostgreSQL PostgreSQL 8.0.22
PostgreSQL PostgreSQL 8.0.15
PostgreSQL PostgreSQL 8.0.13
PostgreSQL PostgreSQL 8.0.9
PostgreSQL PostgreSQL 8.0.8
PostgreSQL PostgreSQL 8.0.7
PostgreSQL PostgreSQL 8.0.5
PostgreSQL PostgreSQL 8.0.4
PostgreSQL PostgreSQL 8.0.3
PostgreSQL PostgreSQL 8.0.2
+ Trustix Secure Linux 2.2
PostgreSQL PostgreSQL 8.0.1
PostgreSQL PostgreSQL 8.0
+ Trustix Secure Linux 2.2
PostgreSQL PostgreSQL 7.4.27
PostgreSQL PostgreSQL 7.4.26
PostgreSQL PostgreSQL 7.4.19
PostgreSQL PostgreSQL 7.4.17
PostgreSQL PostgreSQL 7.4.14
PostgreSQL PostgreSQL 7.4.13
PostgreSQL PostgreSQL 7.4.12
PostgreSQL PostgreSQL 7.4.11
PostgreSQL PostgreSQL 7.4.10
PostgreSQL PostgreSQL 7.4.9
PostgreSQL PostgreSQL 7.4.8
PostgreSQL PostgreSQL 7.4.7
PostgreSQL PostgreSQL 7.4.6
+ Trustix Secure Linux 2.1
PostgreSQL PostgreSQL 7.4.5
PostgreSQL PostgreSQL 7.4.4
PostgreSQL PostgreSQL 7.4.3
PostgreSQL PostgreSQL 7.4.2
PostgreSQL PostgreSQL 7.4.1
PostgreSQL PostgreSQL 7.4
PostgreSQL PostgreSQL 8.4
PostgreSQL PostgreSQL 8.3
PostgreSQL PostgreSQL 8.1.7
PostgreSQL PostgreSQL 8.0.11
PostgreSQL PostgreSQL 7.4.16
PDGSoft Shopping Cart 8.1.2
PDGSoft Shopping Cart 8.1
PDGSoft Shopping Cart 8.0.6
Gentoo Linux
Avaya Voice Portal 5.1
Avaya Voice Portal 5.0 SP2
Avaya Voice Portal 5.0 SP1
Avaya Voice Portal 5.0
Avaya Voice Portal 4.1 SP2
Avaya Voice Portal 4.1 SP1
Avaya Voice Portal 4.1
Avaya Voice Portal 4.0
Avaya Message Networking MN 3.1
Avaya Message Networking 5.2
Avaya Meeting Exchange 5.2 SP1
Avaya Meeting Exchange 5.2
Avaya Meeting Exchange 5.1
Avaya Meeting Exchange 5.0
Avaya Intuity AUDIX LX 2.0 SP2
Avaya Intuity AUDIX LX 2.0 SP1
Avaya Intuity AUDIX LX 2.0
Avaya Aura System Manager 6.0 SP1
Avaya Aura System Manager 5.2
Avaya Aura SIP Enablement Services 5.2.1
Avaya Aura SIP Enablement Services 3.1.1
Avaya Aura SIP Enablement Services 3.1
Avaya Aura SIP Enablement Services 5.2
Avaya Aura SIP Enablement Services 5.1
Avaya Aura SIP Enablement Services 5.0
Avaya Aura SIP Enablement Services 4.0
Avaya Aura SIP Enablement Services 3.1
Avaya Aura Session Manager 6.0
Avaya Aura Session Manager 5.2
Avaya Aura Session Manager 1.1
Avaya Aura Presence Services 6.0
Avaya Aura Communication Manager 5.2
Avaya Aura Communication Manager 5.1
+ Avaya Communication Manager Server DEFINITY Server SI/CS
+ Avaya Communication Manager Server S8100
+ Avaya Communication Manager Server S8300
+ Avaya Communication Manager Server S8500
+ Avaya Communication Manager Server S8700
Avaya Aura Application Enablement Services 5.2.1
Avaya Aura Application Enablement Services 5.2
Not Vulnerable: PostgreSQL PostgreSQL 8.4.2


 

Privacy Statement
Copyright 2010, SecurityFocus