Ruby WEBrick UTF-7 Encoding Cross Site Scripting Vulnerability

Solution:
Updates are available. Please see the references for details.


Yukihiro Matsumoto Ruby 1.8.7-p173

Yukihiro Matsumoto Ruby 1.8.7-p299

Yukihiro Matsumoto Ruby 1.9.1-p378

Yukihiro Matsumoto Ruby 1.8.6-p368

Apple Mac OS X Server 10.6

Yukihiro Matsumoto Ruby 1.8.6-p369

Mandriva Linux Mandrake 2010.1 x86_64

Yukihiro Matsumoto Ruby 1.8.7-p248

Apple Mac OS X 10.6

Mandriva Linux Mandrake 2009.0 x86_64

Yukihiro Matsumoto Ruby 1.8.7-p249

Yukihiro Matsumoto Ruby 1.8.6-p383

Yukihiro Matsumoto Ruby 1.8.6-p399

MandrakeSoft Enterprise Server 5 x86_64

MandrakeSoft Enterprise Server 5

Yukihiro Matsumoto Ruby 1.8.6

Yukihiro Matsumoto Ruby 1.8.6 -p230

Yukihiro Matsumoto Ruby 1.8.6 -p287

Yukihiro Matsumoto Ruby 1.8.6 -p114

Yukihiro Matsumoto Ruby 1.8.7

Yukihiro Matsumoto Ruby 1.8.7 -p22

Yukihiro Matsumoto Ruby 1.8.7 -p21

Yukihiro Matsumoto Ruby 1.8.7 -p71

Yukihiro Matsumoto Ruby 1.8.7 -p72

Yukihiro Matsumoto Ruby 1.9.1 -p376

Yukihiro Matsumoto Ruby 1.9.1 -p429

Yukihiro Matsumoto Ruby 1.9.1

Yukihiro Matsumoto Ruby 1.9.3 dev

Apple Mac OS X Server 10.6.1

Apple Mac OS X 10.6.1

Apple Mac OS X Server 10.6.2

Apple Mac OS X 10.6.3


 

Privacy Statement
Copyright 2010, SecurityFocus