Apple iPhone/iPod touch Prior to iOS 4 Passcode Lock Authentication Bypass Vulnerability

Apple iOS for iPhone and iPod touch is prone to an authentication-bypass vulnerability.

An attacker with physical access to a locked device can exploit this issue to bypass the passcode and access the user's data. This may aid in further attacks.

Versions prior to iOS 4 are vulnerable.

NOTE: This issue was previously covered in BID 41016 (Apple iPhone/iPod touch Prior to iOS 4 Multiple Vulnerabilities) but has been given its own record to better document it.


 

Privacy Statement
Copyright 2010, SecurityFocus