socat 'nestlex()' Command Line Argument Buffer Overflow Vulnerability

Bugtraq ID: 42112
Class: Boundary Condition Error
CVE: CVE-2010-2799
Remote: Yes
Local: No
Published: Aug 02 2010 12:00AM
Updated: Apr 13 2015 09:30PM
Credit: Felix Gröbert
Vulnerable: socat socat 2.0.0-b3
socat socat 2.0.0-b2
socat socat 2.0.0-b1
socat socat 1.7.1.2
socat socat 1.7.1.1
socat socat 1.7.1.0
socat socat 1.7.0.1
socat socat 1.7.0.0
socat socat 1.6.0.1
socat socat 1.6.0.0
socat socat 1.5.0.0
MandrakeSoft Enterprise Server 5 x86_64
MandrakeSoft Enterprise Server 5
Not Vulnerable: socat socat 2.0.0-b4
socat socat 1.7.1.3


 

Privacy Statement
Copyright 2010, SecurityFocus