KDE Okular PDB File Parsing RLE Decompression Buffer Overflow Vulnerability

Bugtraq ID: 42702
Class: Boundary Condition Error
CVE: CVE-2010-2575
Remote: Yes
Local: No
Published: Aug 25 2010 12:00AM
Updated: Apr 13 2015 10:25PM
Credit: Stefan Cornelius, Secunia Research
Vulnerable: Ubuntu Ubuntu Linux 9.10 sparc
Ubuntu Ubuntu Linux 9.10 powerpc
Ubuntu Ubuntu Linux 9.10 lpia
Ubuntu Ubuntu Linux 9.10 i386
Ubuntu Ubuntu Linux 9.10 amd64
Ubuntu Ubuntu Linux 9.04 sparc
Ubuntu Ubuntu Linux 9.04 powerpc
Ubuntu Ubuntu Linux 9.04 lpia
Ubuntu Ubuntu Linux 9.04 i386
Ubuntu Ubuntu Linux 9.04 amd64
Ubuntu Ubuntu Linux 10.04 sparc
Ubuntu Ubuntu Linux 10.04 powerpc
Ubuntu Ubuntu Linux 10.04 i386
Ubuntu Ubuntu Linux 10.04 amd64
SuSE SUSE Linux Enterprise 11 SP1
SuSE SUSE Linux Enterprise 11
Slackware Linux 13.1 x86_64
Slackware Linux 13.1
S.u.S.E. openSUSE 11.3
S.u.S.E. openSUSE 11.2
S.u.S.E. openSUSE 11.1
Mandriva Linux Mandrake 2010.1 x86_64
Mandriva Linux Mandrake 2010.1
Mandriva Linux Mandrake 2010.0 x86_64
Mandriva Linux Mandrake 2010.0
Mandriva Linux Mandrake 2009.0 x86_64
Mandriva Linux Mandrake 2009.0
KDE KDE 4.4.2
KDE KDE 4.4.1
KDE KDE 4.4
KDE KDE 4.3.3
KDE KDE 4.3.2
KDE KDE 4.2.4
KDE KDE 4.0.3
KDE KDE 4.0.2
KDE KDE 4.0.1
KDE KDE 4.0
Gentoo Linux
Not Vulnerable: KDE KDE 4.4.5


 

Privacy Statement
Copyright 2010, SecurityFocus