WebKit for Apple iPhone/iPod touch Prior to iOS 4.1 Remote Code Execution Vulnerability

WebKit for Apple iOS for iPhone and iPod touch is prone to a remote code-execution vulnerability.

An attacker can exploit this issue by tricking an unsuspecting victim into viewing a web page containing malicious content. A successful exploit will result in the execution of arbitrary attacker-supplied code in the context of the user running the affected application.

This issue affects iOS 2.0 through 4.0.2 for iPhone 3G and later and iOS 2.1 through 4.0.2 for iPod touch (2nd generation) and later.


 

Privacy Statement
Copyright 2010, SecurityFocus