Qt Creator Insecure Library Loading Arbitrary Code Execution Vulnerability

Qt Creator is prone to an insecure library loading vulnerability.

An attacker can exploit this issue by placing a malicious library file in the current working directory and enticing a legitimate user to run QT or the QT Creator application. Successful exploitation will allow an attacker to execute arbitrary code in the context of the user running the affected application.

Qt Creator 2.0.0 and prior are affected.


 

Privacy Statement
Copyright 2010, SecurityFocus