PostgreSQL PL/Perl and PL/Tcl Local Privilege Escalation Vulnerability

Bugtraq ID: 43747
Class: Design Error
CVE: CVE-2010-3433
Remote: No
Local: Yes
Published: Oct 04 2010 12:00AM
Updated: Apr 13 2015 08:56PM
Credit: Tim Bunce
Vulnerable: Ubuntu Ubuntu Linux 9.10 sparc
Ubuntu Ubuntu Linux 9.10 powerpc
Ubuntu Ubuntu Linux 9.10 lpia
Ubuntu Ubuntu Linux 9.10 i386
Ubuntu Ubuntu Linux 9.10 amd64
Ubuntu Ubuntu Linux 9.04 sparc
Ubuntu Ubuntu Linux 9.04 powerpc
Ubuntu Ubuntu Linux 9.04 lpia
Ubuntu Ubuntu Linux 9.04 i386
Ubuntu Ubuntu Linux 9.04 amd64
Ubuntu Ubuntu Linux 8.04 LTS sparc
Ubuntu Ubuntu Linux 8.04 LTS powerpc
Ubuntu Ubuntu Linux 8.04 LTS lpia
Ubuntu Ubuntu Linux 8.04 LTS i386
Ubuntu Ubuntu Linux 8.04 LTS amd64
Ubuntu Ubuntu Linux 6.06 LTS sparc
Ubuntu Ubuntu Linux 6.06 LTS powerpc
Ubuntu Ubuntu Linux 6.06 LTS i386
Ubuntu Ubuntu Linux 6.06 LTS amd64
Ubuntu Ubuntu Linux 10.10 powerpc
Ubuntu Ubuntu Linux 10.10 i386
Ubuntu Ubuntu Linux 10.10 amd64
Ubuntu Ubuntu Linux 10.04 sparc
Ubuntu Ubuntu Linux 10.04 powerpc
Ubuntu Ubuntu Linux 10.04 i386
Ubuntu Ubuntu Linux 10.04 amd64
SuSE SUSE Linux Enterprise 10 SP3
SuSE openSUSE 11.3
S.u.S.E. openSUSE 11.2
S.u.S.E. openSUSE 11.1
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux Desktop Workstation 5 client
RedHat Enterprise Linux Desktop version 4
Red Hat Enterprise Linux Workstation 6
Red Hat Enterprise Linux Server 6
Red Hat Enterprise Linux HPC Node Optional 6
Red Hat Enterprise Linux Desktop Optional 6
Red Hat Enterprise Linux Desktop 6
Red Hat Enterprise Linux Desktop 5 client
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux 5 Server
PostgreSQL PostgreSQL 9.0
PostgreSQL PostgreSQL 8.4.1
PostgreSQL PostgreSQL 8.3.8
PostgreSQL PostgreSQL 8.3.6
PostgreSQL PostgreSQL 8.2.14
PostgreSQL PostgreSQL 8.2.6
PostgreSQL PostgreSQL 8.2.4
PostgreSQL PostgreSQL 8.2.3
PostgreSQL PostgreSQL 8.2.2
PostgreSQL PostgreSQL 8.2
PostgreSQL PostgreSQL 8.1.18
PostgreSQL PostgreSQL 8.1.11
PostgreSQL PostgreSQL 8.1.9
PostgreSQL PostgreSQL 8.1.8
PostgreSQL PostgreSQL 8.1.5
PostgreSQL PostgreSQL 8.1.4
PostgreSQL PostgreSQL 8.1.3
PostgreSQL PostgreSQL 8.1.1
PostgreSQL PostgreSQL 8.0.22
PostgreSQL PostgreSQL 8.0.15
PostgreSQL PostgreSQL 8.0.13
PostgreSQL PostgreSQL 8.0.9
PostgreSQL PostgreSQL 8.0.8
PostgreSQL PostgreSQL 8.0.7
PostgreSQL PostgreSQL 8.0.5
PostgreSQL PostgreSQL 8.0.4
PostgreSQL PostgreSQL 8.0.3
PostgreSQL PostgreSQL 8.0.2
+ Trustix Secure Linux 2.2
PostgreSQL PostgreSQL 8.0.1
PostgreSQL PostgreSQL 8.0
+ Trustix Secure Linux 2.2
PostgreSQL PostgreSQL 7.4.26
PostgreSQL PostgreSQL 7.4.19
PostgreSQL PostgreSQL 7.4.17
PostgreSQL PostgreSQL 7.4.14
PostgreSQL PostgreSQL 7.4.13
PostgreSQL PostgreSQL 7.4.12
PostgreSQL PostgreSQL 7.4.11
PostgreSQL PostgreSQL 7.4.10
PostgreSQL PostgreSQL 7.4.9
PostgreSQL PostgreSQL 7.4.8
PostgreSQL PostgreSQL 7.4.7
PostgreSQL PostgreSQL 7.4.6
+ Trustix Secure Linux 2.1
PostgreSQL PostgreSQL 7.4.5
PostgreSQL PostgreSQL 7.4.4
PostgreSQL PostgreSQL 7.4.3
PostgreSQL PostgreSQL 7.4.2
PostgreSQL PostgreSQL 7.4.1
PostgreSQL PostgreSQL 7.4
PostgreSQL PostgreSQL 8.4
PostgreSQL PostgreSQL 8.3
PostgreSQL PostgreSQL 8.1.7
PostgreSQL PostgreSQL 8.0.11
PostgreSQL PostgreSQL 7.4.16
PDGSoft Shopping Cart 8.1.2
PDGSoft Shopping Cart 8.1
PDGSoft Shopping Cart 8.0.6
Mandriva Linux Mandrake 2010.1 x86_64
Mandriva Linux Mandrake 2010.1
Mandriva Linux Mandrake 2010.0 x86_64
Mandriva Linux Mandrake 2010.0
Mandriva Linux Mandrake 2009.1 x86_64
Mandriva Linux Mandrake 2009.1
Mandriva Linux Mandrake 2009.0 x86_64
Mandriva Linux Mandrake 2009.0
Mandriva Linux Mandrake 2008.0 x86_64
Mandriva Linux Mandrake 2008.0
MandrakeSoft Enterprise Server 5 x86_64
MandrakeSoft Enterprise Server 5
MandrakeSoft Corporate Server 4.0 x86_64
MandrakeSoft Corporate Server 4.0
HP Network Node Manager i 9.10
HP Network Node Manager i 9.03
HP Network Node Manager i 9.02
HP Network Node Manager i 9.01
HP Network Node Manager i 8.1
Gentoo Linux
Debian Linux 5.0 sparc
Debian Linux 5.0 s/390
Debian Linux 5.0 powerpc
Debian Linux 5.0 mipsel
Debian Linux 5.0 mips
Debian Linux 5.0 m68k
Debian Linux 5.0 ia-64
Debian Linux 5.0 ia-32
Debian Linux 5.0 hppa
Debian Linux 5.0 armel
Debian Linux 5.0 arm
Debian Linux 5.0 amd64
Debian Linux 5.0 alpha
Debian Linux 5.0
Blue Coat Systems Intelligence Center 3.2.1
Blue Coat Systems Intelligence Center 3.1.2
Blue Coat Systems Intelligence Center 3.1.1
Blue Coat Systems Intelligence Center 2.1.2
Blue Coat Systems Intelligence Center 2.1.1
Blue Coat Systems Intelligence Center 2.1
Blue Coat Systems Intelligence Center 2.0.1
Blue Coat Systems Intelligence Center 2.0
Blue Coat Systems Intelligence Center 3.2
Blue Coat Systems Intelligence Center 3.1
Avaya Voice Portal 5.1
Avaya Voice Portal 5.1
Avaya Voice Portal 5.0 SP2
Avaya Voice Portal 5.0 SP1
Avaya Voice Portal 5.0
Avaya Voice Portal 4.1 SP2
Avaya Voice Portal 4.1 SP1
Avaya Voice Portal 4.1
Avaya Voice Portal 4.0
Avaya Message Networking 5.2.1
Avaya Message Networking 5.2
Avaya Message Networking 3.1
Avaya Message Networking
Avaya Meeting Exchange 5.0 .0.52
Avaya Meeting Exchange 5.2 SP1
Avaya Meeting Exchange 5.2
Avaya Meeting Exchange 5.1 SP1
Avaya Meeting Exchange 5.1
Avaya Meeting Exchange 5.0 SP2
Avaya Meeting Exchange 5.0 SP1
Avaya Meeting Exchange 5.0
Avaya Intuity AUDIX LX 2.0 SP2
Avaya Intuity AUDIX LX 2.0 SP1
Avaya Intuity AUDIX LX 2.0
Avaya Aura System Manager 6.0 SP1
Avaya Aura System Manager 5.2
Avaya Aura SIP Enablement Services 5.2.1
Avaya Aura SIP Enablement Services 5.2
Avaya Aura SIP Enablement Services 5.1
Avaya Aura SIP Enablement Services 5.0
Avaya Aura SIP Enablement Services 4.0
Avaya Aura Session Manager 6.0
Avaya Aura Session Manager 5.2 SP2
Avaya Aura Session Manager 5.2 SP1
Avaya Aura Session Manager 5.2
Avaya Aura Session Manager 1.1
Avaya Aura Presence Services 6.0
Avaya Aura Conferencing 6.0 Standard
Avaya Aura Communication Manager 5.2
Avaya Aura Communication Manager 5.1
Not Vulnerable: PostgreSQL PostgreSQL 9.0.1
Blue Coat Systems Intelligence Center 3.2.2.1


 

Privacy Statement
Copyright 2010, SecurityFocus