IBM WebSphere MQ Invalid Message Remote Buffer Overflow Vulnerability

IBM WebSphere MQ is prone to a buffer-overflow vulnerability because it fails to properly bounds-check user-supplied data before copying it into an insufficiently sized memory buffer.

An attacker can exploit this issue to execute arbitrary code within the context of an affected server. Failed exploit attempts will result in denial-of-service conditions.

The following are vulnerable:

WebSphere MQ 6.x (prior to 6.0.2.11)
WebSphere MQ 7.x (prior to 7.0.1.5)


 

Privacy Statement
Copyright 2010, SecurityFocus