Apple Mac OS X 'i386_set_ldt()' Privilege Escalation Vulnerability

Apple Mac OS X is prone to a privilege-escalation vulnerability.

Successfully exploiting this issue can allow attackers to execute arbitrary code with elevated privileges, leading to a complete compromise of the computer.

Mac OS X versions 10.6 through 10.6.6 and Mac OS X Server versions 10.6 through 10.6.6 are vulnerable.

NOTE: This issue was previously discussed in BID 46950 (Apple Mac OS X Prior to 10.6.7 Multiple Security Vulnerabilities) but has been given its own record to better document it.


 

Privacy Statement
Copyright 2010, SecurityFocus