MuPDF Firefox Plugin 'pdfmoz_onmouse()' Function Stack Buffer Overflow Vulnerability

MuPDF Firefox plugin is prone to a stack-based buffer-overflow vulnerability because the application fails to perform adequate boundary-checks on user-supplied input..

An attacker can exploit this issue to execute arbitrary machine code in the context of the application. Failed exploit attempts will likely crash the webserver, denying service to legitimate users.

MuPDF Firefox plugin 2008.09.02 is vulnerable; other versions may also be affected.


 

Privacy Statement
Copyright 2010, SecurityFocus