FFmpeg Prior to 0.7.8 and 0.8.7 Multiple Remote Code Execution Vulnerabilities

Bugtraq ID: 50760
Class: Boundary Condition Error
CVE: CVE-2011-4351
CVE-2011-4352
CVE-2011-4353
Remote: Yes
Local: No
Published: Nov 21 2011 12:00AM
Updated: Mar 19 2015 08:25AM
Credit: Phillip Langlois of NGS Secure and the vendor.
Vulnerable: Ubuntu Ubuntu Linux 11.10 i386
Ubuntu Ubuntu Linux 11.10 amd64
Ubuntu Ubuntu Linux 11.04 powerpc
Ubuntu Ubuntu Linux 11.04 i386
Ubuntu Ubuntu Linux 11.04 ARM
Ubuntu Ubuntu Linux 11.04 amd64
Ubuntu Ubuntu Linux 10.10 powerpc
Ubuntu Ubuntu Linux 10.10 i386
Ubuntu Ubuntu Linux 10.10 ARM
Ubuntu Ubuntu Linux 10.10 amd64
Ubuntu Ubuntu Linux 10.04 sparc
Ubuntu Ubuntu Linux 10.04 powerpc
Ubuntu Ubuntu Linux 10.04 i386
Ubuntu Ubuntu Linux 10.04 ARM
Ubuntu Ubuntu Linux 10.04 amd64
Mandriva Linux Mandrake 2011 x86_64
Mandriva Linux Mandrake 2011
Mandriva Linux Mandrake 2010.1 x86_64
Mandriva Linux Mandrake 2010.1
MandrakeSoft Enterprise Server 5 x86_64
MandrakeSoft Enterprise Server 5
Gentoo Linux
FFmpeg FFmpeg 0.8.6
FFmpeg FFmpeg 0.8.5
FFmpeg FFmpeg 0.8.3
FFmpeg FFmpeg 0.7.7
FFmpeg FFmpeg 0.7.6
FFmpeg FFmpeg 0.7.4
FFmpeg FFmpeg 0.8.4
FFmpeg FFmpeg 0.8.2
FFmpeg FFmpeg 0.8.1
FFmpeg FFmpeg 0.7.5
FFmpeg FFmpeg 0.7.3
FFmpeg FFmpeg 0.7.2
Debian Linux 6.0 sparc
Debian Linux 6.0 s/390
Debian Linux 6.0 powerpc
Debian Linux 6.0 mips
Debian Linux 6.0 ia-64
Debian Linux 6.0 ia-32
Debian Linux 6.0 arm
Debian Linux 6.0 amd64
Not Vulnerable: FFmpeg FFmpeg 0.8.7
FFmpeg FFmpeg 0.7.8


 

Privacy Statement
Copyright 2010, SecurityFocus