Light HTTPD GET Request Buffer Overflow Vulnerability

Light httpd is prone to a remotely exploitable buffer overflow condition. This overflow can be triggered by sending the server an excessively long GET request. As Light httpd drops user privileges when running, exploitation of this issue may result in the execution of arbitrary attacker-supplied commands with the privileges of the 'nobody' user.


 

Privacy Statement
Copyright 2010, SecurityFocus