GNU glibc Dynamic Linker '$ORIGIN' Multiple Local Privilege Escalation Vulnerabilities

The GNU C library (GNU glibc) is prone to multiple local privilege-escalation vulnerabilities.

Attackers can exploit these issues to execute arbitrary code in the context of setuid applications using the affected library. This may allow the attacker to gain elevated privileges and fully compromise the affected system.

Note: These issues are the result of an incomplete fix for the issue described in BID 44154 (GNU glibc Dynamic Linker '$ORIGIN' Local Privilege Escalation Vulnerability).


 

Privacy Statement
Copyright 2010, SecurityFocus