PostgreSQL CVE-2014-0064 Multiple Remote Buffer Overflow Vulnerabilities

PostgreSQL is prone to multiple remote buffer-overflow vulnerabilities because it fails to adequately bounds-check user-supplied data before copying it into an insufficiently sized buffer.

Attackers can exploit these issues to execute arbitrary code in the context of the affected application. Failed exploit attempts will result in denial-of-service conditions.

Versions prior to PostgreSQL 9.3.3, 9.2.7, 9.1.12, 9.0.16, and 8.4.20 are vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus