Yokogawa CENTUM CS3000 'BKBCopyD.exe' Stack Based Buffer Overflow Vulnerability

Yokogawa CENTUM CS3000 is prone to a stack-based buffer-overflow vulnerability because the application fails to properly bounds-check user-supplied data before copying it into an insufficiently sized buffer.

Successful exploits may allow an attacker to execute arbitrary code with system privileges. Failed attempts will likely cause a denial-of-service condition.

Yokogawa CENTUM CS3000 R3.08.50 is vulnerable; other versions may also be affected.


 

Privacy Statement
Copyright 2010, SecurityFocus