Multiple Vendor LPRM Local Buffer Overflow Vulnerability

Solution:
A patch for OpenBSD has been made available.

SGI has released an advisory (20030406-01-P) containing fixes that address this issue. Users are advised to upgrade as soon as possible.

Debian has revised its advisory. New fixes for Debian 2.2 (potato) are available. Please see the referenced advisory for further details.

Mandrake has released a security advisory (MDKSA-2003:059) containing fixes which address this issue. Users are advised to upgrade as soon as possible.


OpenBSD OpenBSD 3.2

OpenBSD OpenBSD 3.1

BSD lpr 2000.05.07

BSD lpr 0.48

BSD lpr 0.72

lpr-ppd lpr-ppd 0.72

lprold lprold 3.0.48

SGI IRIX 6.5.14

SGI IRIX 6.5.15

SGI IRIX 6.5.16

SGI IRIX 6.5.17

SGI IRIX 6.5.18

SGI IRIX 6.5.19


 

Privacy Statement
Copyright 2010, SecurityFocus