libpng 'png_combine_row()' Heap Buffer Overflow Vulnerability

libpng is prone to heap-based buffer-overflow vulnerability because it fails to properly validate user-supplied input.

Attackers may leverage these issues to execute arbitrary code in the context of the application that uses the affected library. Failed attacks will cause denial-of-service conditions.

libpng 1.6.15 and prior are vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus