APC apcupsd Multiple Buffer Overflow Vulnerabilities

Solution:
Gentoo Linux has released an advisory. Users who have installed sys-apps/apcupsd are advised to upgrade to apcupsd-3.10.5 by issuing the following commands:

emerge sync
emerge -u apcupsd
emerge clean

SCO has released Linux advisory CSSA-2003-015.0 to address this issue.

The vendor has addressed this issue in the latest version of apcupsd.

Fixes available:


APC apcupsd 3.8.2

APC apcupsd 3.8.5

APC apcupsd 3.8.6


 

Privacy Statement
Copyright 2010, SecurityFocus