SQLite Versions Prior to 3.8.9 Multiple Security Vulnerabilities

SQLite is prone to the following vulnerabilities:

1. A stack-based buffer-overflow vulnerability
2. An arbitrary code-execution vulnerability
3. A memory-corruption vulnerability
4. Multiple denial-of-service vulnerabilities

An attacker can exploit these issues to execute arbitrary code in the context of the affected application or cause denial-of-service conditions.

SQLite versions prior to 3.8.9 are vulnerable.


 

Privacy Statement
Copyright 2010, SecurityFocus